安装

兼容性

Vue.js 不支持 IE8 及其以下版本,因为 Vue.js 使用了 IE8 不能实现的 ECMAScript 5 特性。 Vue.js 支持所有兼容 ECMAScript 5 的浏览器

更新日志

每个版本的更新日志见 GitHub

独立版本

直接下载并用 <script> 标签引入,Vue 会被注册为一个全局变量。重要提示:在开发时请用开发版本,遇到常见错误它会给出友好的警告。


开发版本包含完整的警告和调试模式

生产版本删除了警告,26.03kb min+gzip

CDN

可以从 jsdelivrcdnjs 获取(版本更新可能略滞后)。

也可以使用 npmcdn,这个链接指向发布到 npm 上的最新稳定版本。 可以在 npmcdn.com/vue/ 上查看包的源码。

CSP 兼容版本

有些环境,如 Google Chrome Apps,强制应用内容安全策略 (CSP) ,不能使用 new Function() 对表达式求值。这时可以用 CSP 兼容版本

NPM

在用 Vue.js 构建大型应用时推荐使用 NPM 安装,NPM 能很好地和诸如 WebpackBrowserify 的 CommonJS 模块打包器配合使用。Vue.js 也提供配套工具来开发单文件组件

# 最新稳定版本
$ npm install vue
# 最新稳定 CSP 兼容版本
$ npm install [email protected]

命令行工具

Vue.js 提供一个官方命令行工具,可用于快速搭建大型单页应用。该工具提供开箱即用的构建工具配置,带来现代化的前端开发流程。只需一分钟即可启动带热重载、保存时静态检查以及可用于生产环境的构建配置的项目:

# 全局安装 vue-cli
$ npm install -g vue-cli
# 创建一个基于 "webpack" 模板的新项目
$ vue init webpack my-project
# 安装依赖,走你
$ cd my-project
$ npm install
$ npm run dev

开发版本

重要:发布到 NPM 上的 CommonJS 包 (vue.common.js) 只在发布新版本时签入 master 分支,所以这些文件在 dev 分支下跟稳定版本是一样的。想使用 GitHub 上最新的源码,需要自己编译:

git clone https://github.com/vuejs/vue.git node_modules/vue
cd node_modules/vue
npm install
npm run build

Bower

# 最新稳定版本
$ bower install vue

AMD 模块加载器

独立版本或通过 Bower 安装的版本已用 UMD 包装,因此它们可以直接用作 AMD 模块。